Buffer.com down in some regions
Incident Report for Buffer
Resolved
Buffer.com should be back up and working normally for all regions. If you are still seeing any wonkiness, please get in touch with us. Our team will be standing by to help!
Posted 6 months ago. Jun 08, 2018 - 06:28 PDT
Investigating
Buffer.com and other subdomains like faq.buffer.com might be down in some regions at the moment. You might hit errors while trying to open your Buffer dashboard or making changes to your posts. You might also experience an unusual slowness with Buffer. Our team is investigating the issue and hope to resolve this as quickly as we can. We are really sorry for the interruption in your day and will make sure to keep you updated here!
Posted 6 months ago. Jun 08, 2018 - 02:42 PDT