Buffer Android app is down
Incident Report for Buffer
Resolved
The Buffer Android app should work normally now. Thank you so much for bearing with us.
Posted about 1 year ago. Feb 22, 2018 - 06:13 PST
Investigating
The Buffer Android app is down at the moment. We’re so sorry for the interruption! Our team is investigating and will share an update here as soon as we know more.
Posted about 1 year ago. Feb 22, 2018 - 04:45 PST