Some customers are experiencing issues scheduling updates
Incident Report for Buffer
Resolved
We've rolled back a recent change that caused this issue, a refresh of the dashboard should resolve any issues you may have been experiencing.
Posted 3 months ago. May 02, 2018 - 06:42 PDT
Identified
We're currently investigating an issue that impacts different aspects of our scheduling tool. Future queue and custom scheduled times may be impacted.
Posted 3 months ago. May 02, 2018 - 06:34 PDT