Major Outage for Facebook and Meta
Resolved

The issue appears to have been resolved. And, after monitoring, we're confident that things are operating as expected. Thank you for bearing with us as we awaited the fix.

Tue, Mar 5, 2024, 07:08 PM
1 year ago
Affected components

No components marked as affected

Updates

Resolved

The issue appears to have been resolved. And, after monitoring, we're confident that things are operating as expected. Thank you for bearing with us as we awaited the fix.

Tue, Mar 5, 2024, 07:08 PM
2h earlier...

Identified

Meta is currently experiencing a major outage that is impacting both Facebook and Instagram. We're monitoring the situation and will update this page as more information becomes available.

Tue, Mar 5, 2024, 04:20 PM