Resolved
This issue is now resolved! Some posts may still show as "Sending..." but will eventually be moved to the "Sent" tab over the next hour or so.
Thank you for bearing with us as our team worked to get this sorted.
Identified
We've spotted the cause of the issue and are making a change to resolve it. For any post stuck as "Sending..." we'll also ensure they are properly moved to the "Sent" tab.
Investigating
We're investigating instances of posts published with "Share now" still appearing as "Sending" in the queue. These posts have been successfully published, however, and should have been moved to the "Sent" tab. We'll work on getting to the bottom of this issue and update this page accordingly.