Degraded Performance
Resolved·Degraded performance

Buffer has remained stable for the past couple of days while we continued monitoring. As such, we're marking this incident as "Resolved." Thanks for your patience while we worked to ensure Buffer stayed usable.

Thu, May 1, 2025, 10:47 AM
(3 weeks ago)
·
Affected components
Buffer Web App
Updates

Resolved

Buffer has remained stable for the past couple of days while we continued monitoring. As such, we're marking this incident as "Resolved." Thanks for your patience while we worked to ensure Buffer stayed usable.

Thu, May 1, 2025, 10:47 AM

Monitoring

We’ve addressed the issue causing slowness with Buffer and are currently monitoring the app to ensure that performance is stable. We’ll keep you updated with any further developments and provide a final update once we confirm that the service is fully restored.

Tue, Apr 29, 2025, 03:09 PM(1 day earlier)

Investigating

We’re currently experiencing slowness with Buffer. Our team is aware of the issue and is working to resolve it as quickly as possible. We’ll keep you updated on our progress and apologise for the disruption.

Tue, Apr 29, 2025, 02:34 PM(35 minutes earlier)