Resolved
The issue connecting and refreshing X accounts has been resolved. Thanks for your patience.
Identified
The X/Twitter API is experiencing degraded performance related to connecting and refreshing accounts, and analytics might also be affected. X/Twitter has acknowledged the issue and is working on resolving it. We're monitoring it closely and will keep you updated along the way. More information can be found here: https://docs.x.com/status.