Issue with accessing Team settings
Resolved·Degraded performance

The issue affecting the ability of some customers to access Team settings has been fully resolved, and it’s functioning as expected again. If you encounter any further problems, please don’t hesitate to reach out to our team.

Tue, Jun 17, 2025, 09:04 AM
(1 month ago)
·
Affected components
Buffer Web App
Updates

Resolved

The issue affecting the ability of some customers to access Team settings has been fully resolved, and it’s functioning as expected again. If you encounter any further problems, please don’t hesitate to reach out to our team.

Tue, Jun 17, 2025, 09:04 AM

Monitoring

The issue affecting the ability to access Team settings for some organizations has been fixed, and we’re keeping an eye on it to ensure it continues to run smoothly. Thank you for your patience as we worked to resolve this issue.

Tue, Jun 17, 2025, 08:26 AM(38 minutes earlier)

Investigating

Some users are currently experiencing difficulties with accessing Team settings for their organization. Our engineering team is currently investigating the cause, and we'll provide updates here as soon as we know more.

Tue, Jun 17, 2025, 07:53 AM(33 minutes earlier)