Resolved
The issue that was affecting the Team page and actions has been resolved, and users can now resume normal Team actions. We're so sorry for the disruption today!
Identified
We’ve identified the root cause of the issue affecting the Team page (https://publish.buffer.com/settings/team#/team-members) and are in the process of implementing a fix. We sincerely apologise for the disruption and will continue to update you on our progress.
Investigating
Some users are currently experiencing difficulties loading the Team page (https://publish.buffer.com/settings/team). Our engineering team is currently investigating the cause, and we'll provide updates here as soon as we know more.