Resolved
AWS restored services a few hours ago. Buffer services have recovered, and functionality has returned to normal. Please reach out to hello@buffer.com if you're still experiencing any issues.
Identified
Our cloud provider, AWS, is continuing to experience service issues. This may affect the ability to create posts, upload media, publish posts, and perform other actions in Buffer. We are keeping a close eye on their Status Page.
This outage also affects access to our Help Desk and the ability to reply to customers. We are truly sorry for the disruptions and will keep this updated.
Identified
We have confirmed that the issues are related to the AWS outage.
Monitoring
Our cloud provider, AWS, is continuing to experience service issues. This may affect the ability to create posts, upload media, publish posts, and perform other actions in Buffer. We are keeping a close eye on their Status Page.
This outage also affects access to our Help Desk and the ability to reply to customers. We are truly sorry for the disruptions and will keep this updated.