Instagram Analytics Post Impressions & Reach are Missing
Resolved

We're happy to report that Meta has resolved the issue with analytics for Instagram missing.

Please go ahead and Refresh your Instagram channel to ensure we're pulling in the most up-to-date metrics.

We really appreciate you hanging in there with us as we monitored this issue. Let us know if you continue to see any gaps in data. We'd be happy to help!

Wed, Dec 6, 2023, 03:10 AM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

We're happy to report that Meta has resolved the issue with analytics for Instagram missing.

Please go ahead and Refresh your Instagram channel to ensure we're pulling in the most up-to-date metrics.

We really appreciate you hanging in there with us as we monitored this issue. Let us know if you continue to see any gaps in data. We'd be happy to help!

Wed, Dec 6, 2023, 03:10 AM

Identified

We have reported this issue to Meta, and their team is investigating. Meanwhile, we are monitoring this and apologize for any inconvenience.

Mon, Dec 4, 2023, 11:35 PM(1 day earlier)

Investigating

Instagram is currently experiencing some difficulties that are preventing us from displaying Instagram metrics.

As a result of these issues, you may experience missing Instagram Posts & Stories Impressions, Reach, and Engagement Data from November 1st to current (December 4th, 2024).

Mon, Dec 4, 2023, 11:34 PM