Issues with new channel connections to X (Twitter), due to API outage.
Incident Report for Buffer
Resolved
The X (Twitter) team has resolved the issue. You are now able to connect and refresh Twitter channels as expected. Thank you for your patience as we waited for updates and a resolution from their side.
Posted Mar 20, 2024 - 04:36 PDT
Investigating
We're so sorry for the current troubles attempting to connect your X (Twitter) channels to your Buffer account. X's dev team are aware of the issues that are preventing API authentications and logging into X accounts. We will monitor their progress on this, and update our own status page once we have more information.
Posted Mar 19, 2024 - 14:45 PDT
This incident affected: Publishing (Social Network Integrations).