Buffer receiving unusually high number of requests - Login affected
Incident Report for Buffer
Resolved
The high number of requests have subsided and the traffic to Buffer's servers has returned to normal. While this has been resolved, we're keeping a close eye on our systems and you may continue to see some security checks performed by our site prior to login. There is no reason for concern :)

Thanks for bearing with us during this!
Posted Feb 13, 2020 - 10:16 PST
Identified
Buffer's servers have been receiving an unusually high number of requests since 1:00pm EST February 11, 2020. We have been actively leveraging our firewall to mitigate the effect on our product.

While attempting to login or access our apps, you may see pages with captchas, browser verification screens, or access denied pages during this time as we work to filter out malicious traffic from our servers. We apologize for any disruptions to your experience.

All Buffer products and apps should continue to work as normal.
Posted Feb 12, 2020 - 15:03 PST