Billing errors
Incident Report for Buffer
Resolved
Our billing service provider has resolved the issue so you should be able to make changes to your subscription and start a free trial smoothly!
Posted 5 days ago. Jul 10, 2019 - 10:20 PDT
Monitoring
Our billing service provider is currently experiencing an outage which might cause an error if you're making changes to your Buffer subscription - this includes upgrading or downgrading your existing subscription or starting a free trial. We're monitoring closely and will keep you updated here!
Posted 5 days ago. Jul 10, 2019 - 10:08 PDT
This incident affected: Buffer Publish | Web (Dashboard Performance).