Issue w/Publishing Images to Facebook Pages.
Incident Report for Buffer
Resolved
Facebook is reporting that they have made an adjustment on their end which should resolve this issue. Through testing, it does appear that the issue is resolved and newly published images are appearing on the Facebook Page timeline as expected.
Posted Jul 20, 2020 - 05:20 PDT
Monitoring
Over the the weekend of July 11th, we began to see a number of reports regarding updates including images publishing through Buffer to Facebook Pages, but not appearing within the timeline. Instead, these updates only appeared within the Timeline photo album of the Page.

Upon investigation, it has been determined that this is the result of bug within the Facebook API. A report has been logged with the Facebook team and we're awaiting a solution.
Posted Jul 13, 2020 - 11:11 PDT
This incident affected: Buffer Publish (Social Network Integrations).