Issues with some Pro subscriptions being automatically downgraded
Incident Report for Buffer
Resolved
We've moved affected accounts back to the correct subscriptions. If you see anything that doesn't seem right, please let us know!
Posted May 25, 2020 - 02:16 PDT
Investigating
Customers with Pro subscription through iTunes and Google Play are being downgraded automatically. Our team is actively investigating this so we can return customers back to their desired Pro subscriptions.
Posted May 24, 2020 - 10:54 PDT
This incident affected: Buffer Publish (Billing).