Declines for some cards from Ireland and Great Britain
Resolved

This incident has been resolved.

Wed, Mar 30, 2022, 05:44 PM
(3 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Wed, Mar 30, 2022, 05:44 PM

Investigating

We are continuing to investigate this issue.

Mon, Mar 14, 2022, 05:38 PM(2 weeks earlier)

Investigating

Our third-party payment processor has informed us that some customers from Ireland and Great Britain may experience card declines as a result of new strong customer authentication (SCA) enforcement rules. They're investigating and working on a solution.

Mon, Mar 14, 2022, 05:36 PM