Team management page was inaccessible
Resolved

This incident has been resolved.

Tue, Aug 6, 2024, 11:54 AM
(9 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Aug 6, 2024, 11:54 AM

Monitoring

The Team page was temporarily inaccessible. We have identified the issue and shipped the fix, so the page should load normally again. We're monitoring it closely to ensure this is fully resolved.

Tue, Aug 6, 2024, 11:22 AM(31 minutes earlier)