Error: Signing up for Account + Trial
Resolved

The team has been able to resolve the issue. The steps to create an account with a trial should now be working as expected.

Wed, Sep 18, 2024, 08:09 PM
(9 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

The team has been able to resolve the issue. The steps to create an account with a trial should now be working as expected.

Wed, Sep 18, 2024, 08:09 PM

Identified

We're aware of errors for those attempting to create an account via our "Start a Trial" button on our pricing page. We've identified the cause, and our team is working on a solution.

As a workaround, creating a free account still works, and a trial can be started from within your new Buffer account.

Wed, Sep 18, 2024, 07:13 PM(55 minutes earlier)