[Channel Connections] Issues with connecting new Twitter Channels.
Incident Report for Buffer
Resolved
Twitter has updated its Status Page that the issue has been resolved. Thanks for bearing with us. If you do continue to encounter any issues, don't hesitate to reach out.
Posted May 11, 2022 - 11:11 PDT
Monitoring
Twitter has spotted the issue and they are currently working towards the fix. We'll continue to watch for further updates from their team.
Posted May 10, 2022 - 13:01 PDT
Identified
Twitter is currently experiencing an issue with its authorization flow for new channel connections. Sadly, in some instances, this is impacting Buffer's ability to connect to new Twitter channels. Twitter is aware of the issue and is investigating.
Posted May 10, 2022 - 08:09 PDT
This incident affected: Publishing (Social Network Integrations).