Billing errors
Incident Report for Buffer
Resolved
Our billing service provider has marked this issue as resolved, you should be able to make changes to your subscription and start a free trial smoothly!

[Stripe Status: https://status.stripe.com/]
Posted 2 months ago. Jul 10, 2019 - 16:07 PDT
Investigating
Our billing service provider, Stripe, is currently experiencing an outage which might cause an error if you're making changes to your Buffer subscription. This includes upgrading or downgrading your existing subscription or starting a free trial. We're monitoring closely and will keep you updated here!
Posted 2 months ago. Jul 10, 2019 - 15:05 PDT
This incident affected: Buffer Publish (Web Platform).